Liste d'Astuces

>>Windev>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Astuce 1 - Récupérer la liste des ports série d'un pc.

sBase est une chaîne = "HKEY_LOCAL_MACHINE/HARDWARE/DEVICEMAP/SERIALCOMM"
sListe est une chaîne = RegistreListeValeur(sBase)

ListeAjoute(MoiMême,""+gLien(-1))

POUR TOUTE CHAINE sValeur DE sListe SEPAREE PAR RC
 ListeAjoute(MoiMême,RegistreLit(sBase,sValeur)+gLien(ExtraitChaîne(RegistreLit(sBase,sValeur),2,"COM")))
FIN

SI ListeOccurrence(MoiMême) > 0 ALORS ListeSelectPlus(MoiMême,1)

Source: SoftIndustriesBoutique

-------------------------------------------------------------------------------------------------------

 

>>Windev>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Astuce 2 - L'instruction SELON.

Voici une astuce de programmation diffusée par le support technique de pc soft.

« L’instruction conditionnelle « SELON » permet de choisir d’exécuter une action ou une autre en fonction de la valeur d’une expression.
Il est possible de tester une valeur comprise entre un minimum et un maximum, grâce à l’opérateur : min <*< max.
Exemple :
SELON nHeure
CAS 0<*<16>(« Bonjour »)
CAS 16<*<23>(« Bonsoir »)
FIN
 
Source: ZeDev

-------------------------------------------------------------------------------------------------------

 

>>Windev>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Astuce 3 - Comment connaître le serveur SMTP paramétré sur un poste Windows.

PROCEDURE GetServeurSMPT()

LOCAL
sMailCompte est une chaîne

sMailCompte = RegistreLit(« HKEY_CURRENT_USERSoftwareMicrosoftInternet Account Manager »,« Default Mail Account »)

RENVOYER RegistreLit(« HKEY_CURRENT_USERSoftwareMicrosoftInternet Account ManagerAccounts »+sMailCompte,« SMTP Server »)

Source: CodeWindev

-------------------------------------------------------------------------------------------------------

 

>>Windev>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Astuce 4 - Comment transformer une macro VB Excel en code Windev.

Il suffit de faire une macro de tout ce que l'on veux faire sur un fichier excel. Puis récupérer le code généré en visual basic et de remplacer les "." par ">>"


Visual Basic :

Range("A1:F11").Select         // sélection des cellules de A1 à F11

Selection.ClearContents         // efface les cellules sélectionnées 

Devient (après avoir déclaré l'objet OLE xl) :

xl>>range("A1:F11")>>select()

xl>>Selection>>ClearContents()

Source: Laurent30s

-------------------------------------------------------------------------------------------------------

>>Windev>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>